私たち「GMO INTERNET GROUP」のサービスは国内109万・海外2000万のお客様にご利用いただいております。


OS

Red Hat 9からCentOSへの移行

Red Hat 9からCentOSへの移行をおすすめしています。

Red Hat 9をご利用中のお客さまへ

アイルでは新規のお申し込みユーザーさまには、Red Hat 9のOSの提供を終了させていただきました。 理由としては、今後Red Hat 9のセキュリティパッチが提供されない事となりお客さまのサーバーのセキュリティに対して重大な影響を及ぼす可能性があると判断したためです。 それに伴い、弊社では現在Red Hat 9をご利用中のお客さまへOSの変更をご検討いただきたいと考えております。

どうすれば良いか

弊社では、Red Hat 9をご利用中のお客さまへCentOSへのOS変更をお勧めいたします。CentOSとは、Red Hat Enterprise Linux互換のOSです。CentOSの特徴として、他の商用Linux製品よりもセキュリティパッチのリリースが迅速であることが挙げられます。

そのためセキュリティ保持の観点から、アイルではCentOSへの移行をお勧めしております。

補足

セキュリティパッチの提供について

Red Hat 9に関してはRed Hat社が提供するフリーのOSとなっております。セキュリティパッチに関しましてはFedora Legacyプロジェクトが提供元となっておりました。
Fedora LegacyプロジェクトではRed Hat 9のセキュリティパッチ情報の提供終了を正式にアナウンスしておりませんが、現状アップデートの提供は行われておりません。
今後のセキュリティパッチの提供についても行われない可能性が高く、OSの脆弱性が発見された時にご利用されておりますお客さまのセキュリティリスクが高まる事となります。

ソフトウェアバージョンの違いについて

Red Hat 9からCentOSにOSを変更した場合、初期インストールソフトウェアが異なります。CentOS側にて、Red Hat 9との相違がある箇所を赤字で表記しております。
お客さまのシステム動作に問題がないか、念のためご確認いただきますようお願いいたします。

※CentOS側にてRed Hat 9と相違がある箇所は赤字で表記しています。

OS Red Hat 9 CentOS 3.6
管理ツール webmin/なし PLESK HDE Controller webmin/なし PLESK HDE Controller
Web サーバー httpd-2.0.40(apache) hde-apache-1.3.33 httpd-2.0.46
FTP サーバー vsftpd-1.1.3 ※1 psa-proftpd-1.2.10 hde-proftpd-1.2.10 vsftpd-1.2.1 psa-proftpd-1.2.10 hde-proftpd-1.3.0
SMTP サーバー sendmail 8.12.8 psa-qmail-3.0.8 qmail-1.03-28HDE sendmail 8.12.11 psa-qmail-1.03 qmail-1.03
postfix-1.1.11 postfix-2.0.16
POP サーバー imap-2001a courier-imap-3.0.8 vpo pmail-5.4.8 ※2 imap-2002d courier-imap-3.0.8 vpopmail-5.4.10
DNS サーバー bind-9.2.1 bind-9.2.4
プログラミング言語ほか php-4.2.2 php-4.3.2-psa hde-php-4.3.8 ※4 php-4.3.2
perl-5.8.0 perl-5.8.0
データーベース mysql-3.23.54a mysql-3.23.58 ※4 mysql-s3.23.54a mysql-3.23.58
postgresql-7.3.2 ※3 postgresql-7.3.4 ※3 postgresql-7.3.2 ※3 rh-postgresql-7.3.15
SSH openssh-3.5p1 openssh-3.6.1
shell bash-2.05b bash-2.05b-41.5.centos.0
SSL 128bit 128bit
メーリングリスト mailman-2.1 mailman-2.1.1 majordomo-1.94(HDE版) mailman-2.1.5.1-25.rhel3.5 majordomo-1.94.5-9.1HDE

※ webmin の場合、 proftpd-1.2.9 が追加されます。
※ IMAPサーバーは courier-imap-3.0.8 (HDE版) です。
※ postgresql はコマンドライン上のみとなります。
※ 管理ツールに不具合は生じる可能性があるため、以下のバージョンアップはおすすめしておりません。
 【管理ツールがPLESKの場合】PHPおよびMySQLのバージョンアップ。
 【管理ツールがHDEの場合】 PHPのバージョンアップ。